#186 Error with mount points / tool names' case sensitivity in CSS references

v1.0.0
closed
sf-2 (994)
General
nobody
2015-08-20
2010-07-07
Anonymous
No

Originally created by: sf-overlords

Created by: rcopeland
Created date: 2010-04-06 20:04:10.875000
Assigned to:rcopeland

This includes both the code to downcase mount points and project names on creation and a migration to move existing mount points and project names.

Related

Tickets: #7958

Discussion

  • Anonymous - 2010-07-07

    Originally by: sf-overlords

    Post by rcopeland:
    Rick Copeland wrote:

    So what happens if I comment on this ticket?

    And then reply to the comment?

     
  • Anonymous - 2010-07-07

    Originally by: sf-overlords

    Post by mramm:
    test

    On Wed, Apr 7, 2010 at 5:38 PM, Rick Copeland
    186@tickets.forge.projects.in.sf.net wrote:

    Rick Copeland wrote:

    So what happens if I comment on this ticket?

    And then reply to the comment?

     
  • Anonymous - 2010-07-07

    Originally by: sf-overlords

    Post by rcopeland:
    This is me, replying to a ticket status update.

    On Wed, Apr 7, 2010 at 3:41 PM, Ticket 186 186@tickets.forge.projects.in.sf.net wrote:

    Status updated: u'open' => u'closed'
    _est_time_days updated: None => 0

     
  • karsten

    karsten - 2011-09-23

    This is still a problem, at least on master. Did this make it into some other development branch?

    To reproduce:

    Create a wiki tool on a project, then visit the wiki page. The wiki.css will be sought here (for example):
    - https://a.fsdn.com/allura/nf/1316537711/ew/tool/wiki/css/wiki.css
    but will only be findable here:
    - https://a.fsdn.com/allura/nf/1316537711/ew/tool/Wiki/css/wiki.css

    One easy fix would be to change all of the entry points for the apps to be lowercase. Actually making the mount point case insensitive would also work, as suggested above.

    • Description has changed:

    Diff:

    
    
    • status: closed --> open
    • milestone: --> limbo
     
  • Dave Brondsema

    Dave Brondsema - 2011-09-27

    Hi Karsten, for the wiki, Wiki/css/wiki.css does exist but it is empty. The CSS reference is not downcased but it's accurate and works. Are you seeing a problem where the CSS reference is not working?

     
  • karsten

    karsten - 2011-09-28

    Dave: I have recreated the problem on my "personal" project:

    https://sourceforge.net/u/bollwyvl/wikixyz/Home/

    It has a link to:

    http://a.fsdn.com/allura/nf/1317156362/_ew_/tool/wiki/css/wiki.css

    The CSS file in question is missing, while replacing the first instance of "wiki" with "Wiki" yields an empty file. Of course, this isn't a very important file to miss! But the 404 is still happening.

    In trying to build a tool, I couldn't get my CSS (or anything in my nf folder) to load, following the pattern of the wiki app. After I changed my mount point in my tool's setup.py (and the name of my asset folder in nf) to be lowercase, everything worked.

    This condition is not demonstrated on the initial test data, as that gets correctly installed (to "Wiki") whereas subsequent project/tool registrations will show "wiki". So the problem appears to occur when a tool is being installed, but I haven't investigated far enough down the controller to offer any more insight, because the lowercase workaround did the job for me.

    Thanks for looking at it?

     
  • Dave Brondsema

    Dave Brondsema - 2011-09-28

    Thanks for the good example. This might also be an issue with consistency of how we use tool names, default mount points, current mount point, etc. Original commits git log --grep='\[#186\]' are in master, but they were long ago and we may have regressed.

     
  • Dave Brondsema

    Dave Brondsema - 2011-09-28
    • milestone: limbo --> forge-oct-14
     
  • Dave Brondsema

    Dave Brondsema - 2011-09-30
    • summary: Make mount points and project shortnames case-insensitive (downcase them) --> Error with mount points / tool names' case sensitivity in CSS references
    • size: 0 --> 2
     
  • Jenny Steele

    Jenny Steele - 2011-10-03
    • status: open --> in-progress
    • assigned_to: Jenny Steele
     
  • Jenny Steele

    Jenny Steele - 2011-10-05
    • status: in-progress --> code-review
    • assigned_to: Jenny Steele --> Wayne Witzel III
     
  • Jenny Steele

    Jenny Steele - 2011-10-05

    This is fixed on allura js/186. To test, make sure the wiki.css file loads correctly on the default installed home tool. Add another wiki tool. Make sure wiki.css also loads there.

     
  • Anonymous - 2011-10-12

    Originally by: algorithms

    • status: code-review --> closed
    • assigned_to: Wayne Witzel III --> Jenny Steele
     

Log in to post a comment.