Right now we have several properties in the Project document starting with trove_, and we have lots of places in the code where we generate the property name with string pasting/interpolation. Better would be to have a single property 'trove' with sub-properties for the various categories. Refactor the model and update the controllers to reflect this.
It also could be nice to store the trove id number, rather than an object id. Not sure how important that is, or ramifications.
Log in to post a comment.