#3150 Error 500 when viewing Git repository [22505] - NEEDS REPO REFRESH

v1.0.0
closed
sf-4 (350)
SCM
2015-08-20
2011-11-02
Chris Tsai
No

https://sourceforge.net/apps/trac/sourceforge/ticket/22505

Error 500 occurs on page http://sourceforge.net/p/abonpro/code/ci/3da3e8b80ac410df67d3cd65993270c774e9e6b2/tree/. This happened after pushing initial commit contents into Git repository. Maybe this caused by Readme file with Cyrillic symbols, but I tried UTF-8 encoding and the same error raised too.

This initially showed a 500 error, then I tried refreshing the repo and it seems stuck at "analyzing" now.

That is, it still shows a 500 when trying the exact link the user provided, but https://sourceforge.net/p/abonpro/code/ is stuck at analyzing.

Discussion

  • Chris Tsai - 2011-11-02

    Might be related to [#2698], but both of the other tickets mentioned in that one are closed, so I figured I'd go ahead and log this as a new ticket.

     

    Related

    Tickets: #2698

  • karsten

    karsten - 2011-11-09

    I am seeing this error as well, while running under mod_wsgi, which since the move to 2.7 has opened up a whole can of worms with the GitPython process stuff.

    The problem is apparently arising in the template code, which eventually gets down to the git command level. It appears the calling of git.repo.git.branch is causing the issue.

    In forgegit.model.git_repo.py, commenting out symbolics_for_commit and letting RepositoryImplementation handle it removes the problem, though the larger problem of not being able to use GitPython in the WSGI process is troubling.

     
  • Rick Copeland - 2012-01-05

    QA:

    (on dev)

    • clone the referenced repo
    • create a git tool
    • push the cloned repo into the git tool
    • note that crap is broken

    (on forge:rc/3150 without resetting mongodb or anything)

    • run the command below, substituting the tool path you created above for "abonpro code"
    • note that crap is no longer broken (and that /bin/kvyt/ in the repo has a filename in cyrillic)

    And if you're really ambitious, you can repeat the 'on dev' steps above except on rc/3150 and observe that crap works.

    When this is pushed, you'll need to run

    allurapaste script /var/local/config/production.ini ../scripts/refresh-all-repos.py -- /p/ abonpro code --all
    
     
  • Rick Copeland - 2012-01-05
    • summary: Error 500 when viewing Git repository [22505] --> Error 500 when viewing Git repository [22505] - NEEDS REPO REFRESH
    • status: open --> code-review
    • assigned_to: Rick Copeland ☕
    • qa: Tim Van Steenburgh
    • size: --> 4
    • milestone: limbo --> forge-jan-06
     
  • Tim Van Steenburgh

    Works as advertised. Merged to dev.

     
  • Tim Van Steenburgh

    • status: code-review --> closed
     
  • Tim Van Steenburgh

    • status: closed --> in-progress
     
  • Tim Van Steenburgh

    Script was run in prod - repo still stuck in 'analyzing' step.

     
  • Rick Copeland - 2012-01-09
    • status: in-progress --> code-review
     
  • Rick Copeland - 2012-01-09

    More updates that should take into account the new-style repository structures

     
  • Tim Van Steenburgh

    Merged to dev.

     
  • Tim Van Steenburgh

    • status: code-review --> validation
     
  • Dave Brondsema

    Dave Brondsema - 2012-01-10
    • milestone: forge-jan-06 --> forge-jan-20
     
  • Tim Van Steenburgh

    • status: validation --> closed
     

Log in to post a comment.