#6000 Git refresh UnicodeDecodeError

v1.0.0
closed
SCM
Cory Johns
2015-08-20
2013-03-22
Dave Brondsema
No

Forking/cloning repo code in project commsy from /nfs/classic/sf-git/c/co/commsy/commsy failed.

I tried a clean refresh and that succeeded, but the repo showed empty and then a regular refresh after that worked ok.

Could try a reclone after we enable git hotcopy again.

  File "/var/local/allura/ForgeGit/forgegit/model/git_repo.py", line 241, in refresh_tree_info
    for o in tree:
  File "/var/local/env-allura/lib/python2.7/site-packages/GitPython-0.3.2.RC1.20130214-py2.7.egg/git/objects/tree.py", line 225, in __iter__
    return self._iter_convert_to_object(self._cache)
  File "/var/local/env-allura/lib/python2.7/site-packages/gitdb-0.5.4-py2.7-linux-x86_64.egg/gitdb/util.py", line 238, in __getattr__
    self._set_cache_(attr)
  File "/var/local/env-allura/lib/python2.7/site-packages/GitPython-0.3.2.RC1.20130214-py2.7.egg/git/objects/tree.py", line 145, in _set_cache_
    self._cache = tree_entries_from_data(ostream.read())
  File "/var/local/env-allura/lib/python2.7/site-packages/GitPython-0.3.2.RC1.20130214-py2.7.egg/git/objects/fun.py", line 73, in tree_entries_from_data
    name_enc = name.decode("utf-8")
  File "/var/local/env-allura/lib64/python2.7/encodings/utf_8.py", line 16, in decode
    return codecs.utf_8_decode(input, errors, True)
UnicodeDecodeError: 'utf8' codec can't decode byte 0x9f in position 11: invalid start byte

Related

Tickets: #6074

Discussion

  • Dave Brondsema
    Dave Brondsema
    2013-03-22

    • size: --> 2
     
  • Dave Brondsema
    Dave Brondsema
    2013-03-22

    This looks like an internal issue in GitPython or with the data in the repo. Probably would be good enough to catch & skip and not worry about trying to decode it properly.

     
  • Dave Brondsema
    Dave Brondsema
    2013-03-22

    We really should try to do better and not show an "empty repo" message in situations like this where just one thing goes wrong.

     
  • Dave Brondsema
    Dave Brondsema
    2013-03-22

    • milestone: forge-apr-05 --> forge-apr-19
     
    • status: open --> in-progress
    • assigned_to: Tim Van Steenburgh
     
    • status: in-progress --> code-review
     
  • Dave Brondsema
    Dave Brondsema
    2013-04-19

    • Milestone: forge-apr-19 --> forge-may-03
     
  • Cory Johns
    Cory Johns
    2013-04-24

    • QA: Cory Johns
     
  • Cory Johns
    Cory Johns
    2013-04-24

    • status: code-review --> closed
     
  • Cory Johns
    Cory Johns
    2013-04-24

    • status: closed --> validation
     
  • Cory Johns
    Cory Johns
    2013-04-24

    Setting to validation so we can refresh the project once deployed, but I confirmed this fixed the affected project on the sandbox.

     
  • Dave Brondsema
    Dave Brondsema
    2013-04-29

    • status: validation --> closed
     
  • Dave Brondsema
    Dave Brondsema
    2013-04-29

    Allura repo had new commits, so did not do a reclone. Did a full refresh and it completed successfully.