#6670 Users should know when their import is done

v1.0.1
closed
General
2015-08-20
2013-09-18
No

We should send an email when each tool is done being imported. Repo clone already sends an email, so that's not needed.

On the project & individual import pages, we should say that an email will be sent (for each tool in the project) so that folks know to wait for that notice that its done.

Related

Tickets: #6624

Discussion

  • Dave Brondsema

    Dave Brondsema - 2013-09-20
    • Size: --> 2
     
  • Tim Van Steenburgh

    • status: open --> in-progress
    • assigned_to: Tim Van Steenburgh
     
  • Tim Van Steenburgh

    Meh. Honestly not thrilled about this solution, although it works fine. Open to discussion of alternative solutions if anyone feels like it.

    One alternative would be to rename import_tool() to do_import() on all the ToolImporter subclasses. Then we could call do_import() from ToolImporter.import_tool(), and keep common logic in ToolImporter.import_tool(). We'd still end up touching every repo, but maybe we'd be better off in the long run? I dunno. Couldn't decide if it was worth doing something like that for this ticket.

    Changes here:

    forge:tv/6670
    forge-classic:tv/6670
    tracwikiimporter:tv/6670
    googlecodewikiimporter:tv/6670
    
     
  • Tim Van Steenburgh

    • status: in-progress --> code-review
     
  • Cory Johns

    Cory Johns - 2013-09-26
    • QA: Cory Johns
     
  • Cory Johns

    Cory Johns - 2013-09-27
    • status: code-review --> in-progress
     
  • Cory Johns

    Cory Johns - 2013-09-27

    I think if we make base.import_tool accept either the EP name or the class (name?) we could reduce the redundancy.

     
  • Dave Brondsema

    Dave Brondsema - 2013-10-04
    • Milestone: forge-oct-04 --> forge-oct-18
     
  • Tim Van Steenburgh

    • status: in-progress --> code-review
     
  • Tim Van Steenburgh

    There is now only only import_tool task, hooray!

    Force-pushed new commits to:

    forge:tv/6670
    tracwikiimporter:tv/6670
    googlecodewikiimporter:tv/6670

     
  • Cory Johns

    Cory Johns - 2013-10-07
    • QA: Cory Johns --> Dave Brondsema
     
  • Dave Brondsema

    Dave Brondsema - 2013-10-07
    • status: code-review --> closed
     

Log in to post a comment.