#4014 Trackers not sending notification mail [25066]

v1.0.0
closed
sf-4 (350)
General
2015-08-20
2012-04-05
Chris Tsai
No

https://sourceforge.net/apps/trac/sourceforge/ticket/25066

Configured my project to send notification mails on every tracker change; no mail is sent, neither on updates nor on new issues.
Tried both mailing list (with sf's noreply set to auto-accept) and my personal address.


This seems to be a result of our project's migration (https://sourceforge.net/projects/packfilemanager/). I installed the Tickets Tool for my personal project for test reasons and there it worked fine.
Other issues I have with the Tickets in packfilemanager:

  • can't create Milestones
  • irratically get "Sorry, can't fulfil this request right now" error message although action worked (for instance creating a new Ticket with Status other than "open")
  • can't filter by Group or Release (our user-defined Fields)

I can create new tickets for those but assuming they stem from the same issue, leave them here for now.

Discussion

  • Dave Brondsema

    Dave Brondsema - 2012-04-09
    • labels: support --> support, migration
    • milestone: limbo --> forge-apr-20
     
  • Dave Brondsema

    Dave Brondsema - 2012-04-09
    • size: --> 4
     
  • Cory Johns

    Cory Johns - 2012-04-12

    Are we sure this is not a side-effect of [#3991]?

     

    Related

    Tickets: #3991

  • Dave Brondsema

    Dave Brondsema - 2012-04-12

    Was [#3991] a display-only bug? (I assumed so) Also, I don't think the setting to send email to an address for all changes shares much with the standard subscription logic.

     

    Related

    Tickets: #3991

  • Tim Van Steenburgh

    • status: open --> in-progress
    • assigned_to: Tim Van Steenburgh
     
  • Tim Van Steenburgh

    Tracker notifications weren't being sent b/c notifications were disabled at the project level, possibly an unintended side-effect of migration. Turned project notifications back on with a mongodb update. Will continue to investigate root cause under [#4073].

     
  • Tim Van Steenburgh

    Error messages were caused by a bug in the tracker notification code which caused a 500 when project notifications were disabled. That is fixed in this ticket.

    Help documentation for how to search/filter by custom fields will be provided by [#2818].

     

    Related

    Tickets: #2818

  • Tim Van Steenburgh

    Edit Milestones page wasn't working b/c the default milestone field was missing, a side-effect of migration. This ticket contains a fix that will create the default milestone field if it's missing. Long-term goal is to refactor the Edit Milestones page [#1855].

    • status: in-progress --> code-review
    • qa: Jenny Steele
     

    Related

    Tickets: #1855

  • Tim Van Steenburgh

    forge:tv/4014

    Code review + run tests.

     
  • Jenny Steele

    Jenny Steele - 2012-04-18
    • status: code-review --> closed
     
  • Tim Van Steenburgh

    • status: closed --> in-progress
     
  • Tim Van Steenburgh

    Figure out why Allura got a 2nd _milestone created and fix it.

     
  • Tim Van Steenburgh

    forge:tv/4014 (force-pushed)

    Code review + run tests. Also try to create some milestones and make sure extra "Milestone" custom fields aren't created.

     
  • Tim Van Steenburgh

    • status: in-progress --> code-review
    • qa: Jenny Steele --> Dave␣Brondsema
     
  • Dave Brondsema

    Dave Brondsema - 2012-04-19
    • status: code-review --> closed
     

Log in to post a comment.